Archiv štítku: linux

Synaptics Touchpad – not working in debian 7 (Jessie)

Create a file: /usr/share/X11/xorg.conf.d/synaptics.conf

In that file put..

Section "InputClass"
     Identifier "Touchpad" # required
     MatchIsTouchpad "yes" # required
     Driver "synaptics" # required
     Option "MinSpeed" "0.5"
     Option "MaxSpeed" "1.0"
     Option "AccelFactor" "0.075"
     Option "TapButton1" "1"
     Option "TapButton2" "2" # multitouch
     Option "TapButton3" "3" # multitouch
     Option "VertTwoFingerScroll" "1" # multitouch
     Option "HorizTwoFingerScroll" "1" # multitouch
     Option "VertEdgeScroll" "1"
     Option "CoastingSpeed" "8"
     Option "CornerCoasting" "1"
     Option "CircularScrolling" "1"
     Option "CircScrollTrigger" "7"
     Option "EdgeMotionUseAlways" "1"
     Option "LBCornerButton" "8" # browser "back" btn
     Option "RBCornerButton" "9" # browser "forward" btn
EndSection

Restart XServer

Bluetooth restart adapter

root@Queeq:/home/xsimi# hcitool scan
Scanning …
Inquiry failed: Invalid argument
root@Queeq:/home/xsimi# hciconfig hci0 reset
root@Queeq:/home/xsimi# hcitool scan
Scanning …
0C:.:..:..:..:.. Jachym 2330c
34:..:..:..:..:.. XSimi
root@Queeq:/home/xsimi#

Pana Music Player for Debian Squeeze 64 bit

Install necessary packages

# aptitude build-dep amarok
# aptitude install kdelibs4c2a qt3-dev-tools libqt3-mt-dev kdelibs4-dev ruby1.9.1-full libxine-dev

Download and unpack source file

# wget http://launchpad.net/pana/1.4/1.4.17/+download/pana-1.4.17.tbz
# tar xvfj pana-1.4.17.tbz

Configure and make

# cd pana-1.4.17/
# ./configure -prefix=`kde-config -prefix` -disable-debug -disable-warnings -with-mp4v2 -with-libmtp -with-libnjb -with-libkarma -with-ifp -with-libgpod
# make -j 4

Create and install package

# checkinstall

Download created package Package

For lyrics to work it is necessary to install ruby-qt and plug-in wiki_lyrics script (download down)

# aptitude install libqt4-ruby1.8
Script

Gnomad 2 for Debian Squeeze

Reason:

I need Gnomad.

Info:

Make with the assistance checkinstall. I don’t fill dependency.  (It is Your Fight)

Download:

AMD64 version:

http://xsimi.cz/linux/gnomad2_2.9.4-1_amd64.deb

i386 version:

http://xsimi.cz/linux/gnomad2_2.9.4-1_i386.deb

Install (as root):

AMD64 version:

wget http://xsimi.cz/linux/gnomad2_2.9.4-1_amd64.deb

dpkg -i  gnomad2_2.9.4-1_amd64.deb

i386 version:

wget http://xsimi.cz/linux/gnomad2_2.9.4-1_i386.deb

dpkg -i gnomad2_2.9.4-1_i386.deb

Mail-Notification for Debian Squeeze with TLS/SSL (Gmail, etc.. support)

Reason:

TLS/SSL option to connect to a mail server is disabled by the Debian maintainer of this package. Apparently he has an issue with the SSL/TLS licensing and as such he has disabled that option. This is dangerous and for some mail servers is it unsupported.

Package creation based on:

http://www.howtoforge.com/repackage_deb_packages_debian_ubuntu

Download:

AMD64 version:

http://xsimi.cz/linux/mail-notification_5.4.dfsg.1-2.2a_amd64.deb

Install (as root):

AMD64 version:

wget http://xsimi.cz/linux/mail-notification_5.4.dfsg.1-2.2a_amd64.deb

dpkg -i mail-notification_5.4.dfsg.1-2.2a_amd64.deb

Mail-Notification for Debian Lenny with TLS/SSL (Gmail, etc.. support)

Reason:

TLS/SSL option to connect to a mail server is disabled by the Debian maintainer of this package. Apparently he has an issue with the SSL/TLS licensing and as such he has disabled that option. This is dangerous and for some mail servers is it unsupported.

Package creation based on:

http://www.howtoforge.com/repackage_deb_packages_debian_ubuntu

Download:

http://xsimi.cz/linux/mail-notification_4.1.dfsg.1-4.1a_i386.deb

Install (as root):

wget http://xsimi.cz/linux/mail-notification_4.1.dfsg.1-4.1a_i386.deb

dpkg -i mail-notification_4.1.dfsg.1-4.1a_i386.deb